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Section I: Introduction
Where to Begin

If you are new to RATS, we recommend that you begin by reading through this guide.

In particular, be sure to read Section IV on using RATS in interactive mode. Then

work through the tutorial in Chapter 1 of the User’s Guide.

If you are an experienced RATS user, we recommend that you look over this guide to

see what is new and different about the RATS interface, and then turn to page xii in

the User’s Guide for an overview of the new features in Version 7.

What’s Included in Your RATS Package
In addition to this guide, your RATS package should include a CD ROM containing the

RATS software, as well as the User’s Guide and Reference Manual books (except for

Classroom RATS, which is available without the hard-copy versions of the manuals).

The User’s Guide provides general instructions on using RATS, discusses a variety of

topics, and includes extensive examples. The Reference Manual provides a detailed

description of each instruction and function in RATS, as well as other elements of the

RATS language.

Estima offers two versions of RATS for most platforms: RATS and RATS Professional.

The two versions are identical except that the Professional version includes the

Census Bureau’s X11 seasonal adjustment routine and support for some additional

database formats, including ODBC/SQL and (except on Macintosh systems) FAME
®

format databases.

In addition to the RATS software itself, your RATS CD includes

• Copies of the User’s Guide and Reference Manual in Adobe PDF format.

• A menu-driven data handling utility called RATSDATA. This is of less impor-

tance these days, because most of its functionality has been incorporated into

RATS itself. However, some users may still find the stand-alone version useful.

• A large selection of full example programs (many of which are discussed in the

manuals), including worked examples from many popular econometrics

textbooks (installed in the folder “TextbookExamples”) and programs replicat-

ing results from some well-known econometric papers (in the “PaperResults”

folder).

• Dozens of RATS procedures. These are routines written in the RATS language

that make it easy for you to implement complex tasks, such as unit-root

testing, automated model selection, and so on, with a single call to the proce-

dure. Many other procedure and example programs are available for down-

loading free of charge from our web site at www.estima.com. Many of these

have been written by RATS users from around the world.

• Additional PDF files listing all of the procedure and example files included

with RATS, including with a brief description of each.
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 System Requirements
WinRATS

• A Pentium or better CPU.

• Windows 98 or later. RATS 7 has been tested on 98, NT, 2000, XP, and Vista.

• A minimum of 8 Mb of available RAM. The amount of memory available to

RATS determines the amount of data you can handle. See “How RATS uses

Memory” on the next page for more information.

• A hard disk drive with at least 50 Mb of space available (100Mb if you want to

install all the examples and procedures).

• A CD-ROM drive.

MacRATS
• A PowerPC- or Intel-based Mac, running OS X 10.3 or later.

• A hard disk drive with at least 50 Mb of space available (100Mb if you want to

install all the examples and procedures).

• A CD-ROM drive.

UNIX/Linux RATS
• Please see the UNIX RATS installation guide.

Your Serial Number
Your serial number is printed on the CD jacket. It has a form such as WExxxx,

WXxxxx, or NExxxx depending on which version you purchased, and whether it is a

single-user license or a network license. The serial number is your key to getting

updates and technical help. On some platforms, you will be prompted for your serial

number when installing the program. You can then view the serial number at any

time by selecting the About RATS operation (found on the Help menu on Windows/

UNIX, on the RATS menu on Macintosh).

If you are not prompted for the serial number during installation, you can also use

File–Preferences (RATS–Preferences on Macintosh) to enter and save your serial

number. You may also want to record this number where you can find it easily, such

as in the front of your manual.

Please use the convenient on-line registration form available on our web site

(www.estima.com) to register your software. This is especially important if you

bought the program through a dealer or through your purchasing department, as we

will be unable to send you newsletters and other notices without an address.

Please note: We never sell or give out contact information to anyone.
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How RATS Uses Memory
RATS performs all of its computations on data stored in memory, which allows RATS

to run very quickly. This means that you will need to have enough memory available

for RATS to store your data, as well as arrays, scalars, strings, and other variables

you define. RATS will also need some temporary space for doing calculations (such as

inverting arrays).

Each real number (series entry, array or formula element, etc.) requires 8 bytes of

memory storage. To estimate the memory requirements of a given program, just

multiply the total number of series you will be using by the number of observations

per series, and multiply by 8. For example, 200 series of 200,000 observations each

(for a total of 40,000,000 data points) would require approximately

(200x200,000x8)=320,000,000 bytes, or approximately 320 Mb, of memory.

As you can see, most modern personal computers will allow you to handle fairly large

data sets. For example, on a machine with 1 Gb of RAM, your operating system and

other applications may use as much as half of the available memory or more. How-

ever, you are likely to still have 400 Mb or more available for handling your data,

which would allow you to work with several million data points. Virtual memory can

provide additional capacity, but will slow down computations significantly.
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Section II: Installing RATS
For UNIX/Linux Users

Please see the UNIX RATS installation guide included with your software.

For Macintosh Users
To install RATS on your system, just drag the MacRATS folder from the CD to your

hard drive.

If you do not want to install all of the files included with RATS, first create a new

folder for RATS on your hard drive, then open the RATS folder on the CD and copy

over only the components you wish to install. See “What Is Included?” on the next

page for descriptions of the various components.

For Windows Users
To install RATS on your system:

1. Insert the CD in your CD ROM drive.

2. In most cases, the installation program still start automatically. If the

installation program does not start automatically, you can run it manually by

selecting the Run operation from the Start menu, typing in “d:setup”

(where “d” is the drive containing the CD), and clicking on “OK”.

The installation software will ask you where you want the software to be installed.

By default, WinRATS will be installed in the subdirectory:

C:\Program Files\Estima\WinRATS 7\

This conforms with standard practice for Windows applications.

However, you may find it more convenient to install RATS in a directory that is

easier to locate and work with, such as:

C:\rats\

After selecting the drive and directory on which you wish to install RATS, you will be

given the choice of doing a standard, minimum, or custom installation. The standard

installation installs all the items described on the next page. The minimum installa-

tion installs only the RATS and RATSDATA application files, omitting the examples,

procedures, and documentation files. The custom installation allows you to select the

components you wish to install.

See “What Is Included?” on the next page for descriptions of the various components.
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What Is Included?
In addition to the RATS software itself, your RATS CD includes many other compo-

nents, including a PDF-format copies of the manuals and other documentation as

well as extensive collections of example programs and procedures. Below is an

overview of the various components provided with RATS:

Program Files This includes the RATS program itself and the RATSDATA data-

handling utility program.

Auxiliary Files These are additional support files required by RATS. You should

install these if you are installing the Program Files.

Documentation This includes copies of this Getting Started booklet, the User’s

Guide, and the Reference Manual, lists of procedure and ex-

ample files, and other documents in Adobe PDF format files.

You will need a copy of Adobe Acrobat® Reader or a compatible

utility to view these. You can download the software free of

charge from www.adobe.com.

Examples and This includes a variety of complete example programs and data

Procedures sets, and a number of RATS “procedures”—pre-written callable

routines for performing tasks that require a sequence of RATS

instructions. These are ordinary text files you can open and

examine with the RATS Editor. We strongly recommend that

you install these, as they are a very useful resource for using

and learning various techniques in RATS. Additional procedures

and examples are available from our web site

(www.estima.com).

Enders Book The RATS Programming Manual, by Walter Enders, is in-

cluded with RATS in Adobe PDF format. This is a very useful

guide to more advanced programming techniques, which

Professor Enders has graciously provided free of charge to the

RATS community. This was written for Version 5 of RATS, but

most of the information applies equally well to Version 7.

Textbook These are complete worked example programs and data sets for

Examples many popular econometric textbooks.

Help Files The Help files for RATS and RATSDATA. These provide quick

references to all of the instructions and functions in RATS and

general instructions on using RATS and RATSDATA.

Paper Results These are example programs replicating results from some

important econometric papers.
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Section III: Using RATS–An Overview
Introduction

RATS is, for the most part, a command–driven application. You work in RATS by

supplying an instruction, or set of instructions, for RATS to process. For example, you

use the command LINREG to tell RATS to estimate a least squares regression. You

can save your work as a program file, and you can rerun these saved programs at

any time with just a couple of mouse clicks.

The great advantage of this approach is that as you are doing your analysis, you are

creating a sequence of RATS instructions that you can use to reproduce and verify

your results at any time—quickly, easily, and reliably. We believe that this ability to

reproduce results is a vital, but often overlooked, aspect of any useful statistical

research.

Version 7 also offers many menu-driven Wizards for many common tasks, including

reading in data, doing transformations, estimating models, and doing hypothesis

tests. You simply select the desired options from a dialog box, and the Wizard will

generate and execute the appropriate RATS instructions.

These point-and-click Wizards simplify the learning process and help you get work

done quickly, while still providing you with a complete “program” of instructions you

can rerun at any time, either to reproduce your results or expand your analysis.

Interactive Mode vs. Batch Mode
RATS can be used in two modes: interactive and batch.

In interactive mode, you work with the RATS Editor. This is a special text-editor that

can interpret and execute RATS instructions, and provides access to the menu-driven

Wizards. We call this interactive mode because it makes doing your analysis an

interactive process.

For example, suppose you execute a few instructions to estimate a regression model.

After viewing the output, you decide to change your model slightly. With the RATS

Editor, you can simply modify and re-execute the regression instruction itself,

without having to re-run your entire program. You can also execute existing pro-

grams with just a couple of mouse clicks.

In batch mode, you supply RATS with a complete RATS program. RATS automatically

executes all of the instructions in the program in order, and saves the resulting

output to a file.

Instructions on using RATS interactively begin on page 9. See page 33 for details on

batch mode.
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Section IV: Using RATS in Interactive Mode
Starting RATS

To start WinRATS in interactive mode, click on the Start menu, open the “WinRATS 7”

folder, and click on the WinRATS icon. For MacRATS, click on the MacRATS program

icon. For UNIX, click on the “ratsx” executable file or type ratsx at the command

prompt.

This loads the RATS interactive interface, which we call the RATS Editor. You will

see the RATS menu bar, the toolbar, and an empty worksheet window called

NONAME00.PRG. Whether or not RATS opens the empty worksheet at start–up is

something you can control using the Preferences... operation on the File menu (on the

RATS menu for Macintosh users).

The RATS Editor
The RATS editor is a text editor and interface to RATS, which allows you to:

• execute, modify, and re-execute RATS instructions. You can execute instruc-

tions line-by-line, or select a whole set of instructions and then execute them

with a single keystroke or mouse-click.

• use menu- and dialog-driven Wizards to perform a variety of tasks.

• edit any text file. For example, you can store RATS instructions on a file for

later execution in batch mode, examine and edit output files, and so on.

• access extensive on-line help information covering the editor and all RATS

instructions (Windows only—help is accessed externally on Mac and UNIX).

• display, save, load, and print RATS graphs. You can also export graphs to

other common graphics file formats for importing into other applications.

• create or edit data series on RATS format files.

In the next few pages, we’ll walk you through some basic features of the RATS Editor,

and then provide more detailed information.

Executing Instructions and Ready/Local Mode
The RATS editor is a standard text editor with a twist: if you hit the <Enter> key on

a line of text, that line will be executed as a RATS instruction. To try this, start RATS

and type SHOW MEMORY followed by <Enter>. You will get output showing some

statistics on the amount of memory available to RATS.

You will find there are times when you want RATS to stop bothering you and just let

you edit your text. On the Macintosh, just hit the <Return> key. This inserts a line

break without executing the current command.

In Windows and UNIX, just click on the “Ready/Local” toolbar icon ( ) or type

<Ctrl>+L. This switches you into “Local” mode, where hitting <Enter> simply
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inserts a carriage return. For example, if you enter local mode, type SHOW MEMORY,

and then hit <Enter>, nothing will happen, except that the cursor will move to the

next line. To go back to Ready mode, click on the “Local/Ready” icon or hit <Ctrl>+L
again. If you use the arrow keys to put the cursor anywhere on the SHOW MEMORY
line, and hit the <Enter> key, RATS will execute the instruction.

Important Note: RATS allows you to have several windows open at a time, but it

will only execute instructions from the window designated as the input window. See

page 13 for details.

Executing Existing Commands
Chapter 1 of the User’s Guide includes a step-by-step example which introduces

many of the key RATS instructions. Right now, we’ll show you how to execute some of

that example. Don’t worry about what these instructions do—we explain that in

Chapter 1.

First, type in the following lines without executing them (by putting RATS in Local

mode, or by using the <Return> key on the Macintosh) :

calendar(m) 1959:1
allocate 1996:2
open data basics.xls
data(format=xls,org=columns)
table

If you are using Windows or UNIX, now put RATS back into Ready mode.

One way to execute these commands is to do it one line at a time. Just use the mouse

or arrow keys to put the cursor on the first line (the CALENDAR line). The cursor can

be anywhere in the line. Now hit the <Enter> key. RATS will execute the first

command, which sets the frequency and starting date for this session, and the cursor

moves to the second line. Keep hitting <Enter> to execute each line in succession.

The TABLE command should generate a table of basic statistics for the series read in

by the DATA command.

However, when you need to execute a block of instructions, it is usually easier and

faster to select (highlight) the whole block of instructions and execute them all with a

single keystroke or mouse click. You can select text using standard keyboard or

mouse techniques:

• With the keyboard: Hold down the <Shift> key, and then press ↑, ↓, <PgUp>
or <PgDn>. For this example, move the cursor up to the line beginning with

CALENDAR (using ↑). Hold down the <Shift> key and press the ↓ key five

times. All five lines should be marked in inverse video or in color.

• With the mouse: You can select text in several ways. For example, you can

point the cursor at the CALENDAR line, press and hold down the mouse button,

and drag the cursor until you’ve selected all five lines. Or, you could click on

the first line, then hold down the <Shift> key and click on the last line.
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To try this, select all the lines from CALENDAR down to TABLE, and either hit the

<Enter> key or click on the “Run” icon ( ) on the toolbar to run the commands

again.

You may have noticed that the “Run” icon changes to the “Stop” icon ( ) while

RATS is executing the instructions. This indicates that RATS is busy executing

instructions, and that you can click on “Stop” to interrupt the execution of these

instructions. The “Run” icon returns as soon as the task is complete and RATS is

ready to accept more instructions.

If you want to select all of the text in a window (if, for instance, you want to run a

complete program), you can choose the Select All operation from the Edit menu, or

click on the “Select All” icon ( ).

The process of selecting text is key to many operations, such as printing or saving

selected portions, cutting and copying text, and so on.

Saving and Opening Programs and Output
You can use the Save or Save As... operations on the File menu to save your pro-

grams or output to disk.

To open a program or output file you’ve saved to disk, just choose the Open... opera-

tion from the File menu. You can also use the Recent Files operation on the File

menu to open files used previously.

Printing Text
You can print your programs and output by selecting the Print... operation from the

File menu. This prints the contents of the active window. To print just a portion of

the text in a window, first select (highlight) the text with the keyboard or the mouse,

then select Print.... RATS will ask if you want to print just the selected text or the

entire window contents.

Working with the RATS Editor
The RATS editor allows you to work with multiple “windows” of information. For

example, you can enter RATS instructions in one text window and send the output to

another text window, or have several files open at one time. In addition to text

windows, RATS uses several other types of windows for displaying information. In

the next few pages, we describe the basics of working with windows, and then cover

each of the menu operations in detail.
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Definitions
RATS uses six types of windows to display information:

Text window Text windows are used to view and edit text files and

execute RATS instructions. See the preceding pages for

details.

Graph window Graphs are displayed in graph windows. When a graph

window is active, you can use File–Save As... to save the

graph in any of several formats, File–Print to print the

graph, and Edit–Copy to copy the graph to the clipboard.

Series List window The Series List window displays a list of the series cur-

rently stored in memory. You can open this by selecting

Series Window from the View menu (or Show Series Win-

dow from the Data menu). From this window, you can

double-click on a series to edit it; use the toolbar icons or

View menu operations to generate graphs and summary

statistics; or export data using File–Export...

Spreadsheet/Report Many RATS instructions, such as FORECAST, IMPULSE, and

REPORT include a WINDOW option that allows you to direct

output to a spreadsheet-style window. You can copy and

paste information from these windows into other applica-

tions, or use File–Export... to export the data into a variety

of different file formats.

Series Editing window Series Editing windows are used for editing individual data

series. You can edit series stored in memory (by double-

clicking on a series in a Series List window) or series stored

on RATS format data files (by using the Open RATSDATA or

New RATSDATA operations on the File menu, or by using

the DEDIT and EDIT instructions). The RATSDATA utility

also uses these windows for creating or editing series.

Datafile List window If you open or create a RATS format file (using File–Open

RATSDATA or File–New RATSDATA), RATS displays the

contents of the file in a Datafile List window. The window

shows the names, number of observations, frequency, entry

range, and comments (if any) for each series. You can

double-click on a series to view or edit the series, while

toolbar operations and corresponding View menu operations

allow you create new series, rename existing series, gener-

ate several types of graphs, and compute summary statis-

tics. RATSDATA also uses datafile list windows to display

series lists.
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Here are some other terms that we will use:

Active window This is the front or top window—the window you are

currently working with. You can switch windows by clicking

on the window you want or by using the Window menu (see

page 27). You can only edit text in a window when it is

active.

Input window At any given moment, one and only one of the open text

windows is designated as the “input window.” RATS will

only execute instructions from that window. To execute

instructions, this input window must be the active (front)

window. To make a different window the input window,

switch to the desired window (make it the active window)

and select the Use for Input operation from the Window

menu or the  icon.

Output window RATS sends any output it generates to the window desig-

nated as the “output window.” This can be the same window

as the input window (output is inserted immediately after

an instruction or block of instructions), or a different one.

You can use the Use for Output operation on the Window

Menu (or the  icon) to make the active window the output

window.

RATS shows which windows are input and output by appending {i} (for input), {o}
(output), or {io} (both input and output) to the window title, both on the window

title bar and on the window list in the Window menu.

Window Basics
When you start RATS in interactive mode, the program normally opens an empty

window labelled NONAME00.PRG. Since it is the only window, this window is the

active window, the input window and the output window. RATS will execute any

instructions you type in, and will insert any output in this window.

If you want to work with a specific file, the simplest procedure is to first close the

empty window and then open your file. The new window will be active, input and

output.

If you open a new window without closing NONAME00.PRG first, the new window will

be the active window, but not the input or output window. You cannot execute

instructions in this new window until you make it the input window, which you can

do using the Use for Input operation on the Window menu, or the  icon.

Similarly, Window–Use for Output (or the  icon) makes the active window the

output window.
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Three Window Setups
We tend to use the text windows in one of three ways:

1. For quick work, we simply start up RATS and work with the NONAME window.

If you aren’t really interested in developing a set of RATS instructions to

execute later and just want some quick answers, this is the simplest setup.

2. To test or run existing programs, we close NONAME (or configure RATS not to

open a NONAME window—see page 15), open our file and run it as the sole

window. We save or print whatever segments of the output that we need.

3. To develop a new (or existing) program, we designate one window as the

input window, and a second window as the output window. With input and

output in separate windows, it is much easier to keep a copy of the instruc-

tions that we decide we like.

The  and  toolbar icons provide easy ways to get this split-window

setup—they automatically open a second window, designate it as the output

window, and tile the two windows horizontally or vertically, respectively.

Working With Graphs
RATS normally associates each graph you create or load from disk with its own graph

window. This allows you to keep several graphs in memory at a time.

To print or save a graph, you just need to bring the desired graph window to the

front and select File–Print or File–Save As... or click on the “Print” ( ) or “Save”

( ) icons. You can also save graphs using the OPEN PLOT or ENVIRONMENT GSAVE
instructions prior to drawing the graphs—see Chapter 3 in the User’s Guide for

details.

You can configure RATS to use only one graph window. In that case, the first graph

opens a new graph window. Any later graphs simply replace the previous graph in

the same window. See “Customizing the RATS Editor” on page 15.

See the “Graphics” chapter in the User’s Guide for further information.

The Toolbar
RATS includes a “Toolbar” that allows you to accomplish many operations quickly by

simply clicking on icons with the mouse. See page 28 for details on the toolbars.

Pop-Up Menus
RATS also provides contextual, or “pop-up”, menus for the various types of windows.

If you right-click on a window or object (Ctrl+click on Macintosh), the program

displays a short menu of operations that you can apply to that window or object. Just

click on an operation to select it. For example, on text windows you can use pop-up

menus to do most of the operations available on the Edit menu with a minimum of

effort.
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Customizing the RATS Editor
The Preferences... operation on the File menu (on the RATS menu for Macintosh

users) lets you customize various aspects of the RATS environment. Selecting the

Preferences operation brings up this dialog box:

You can use the Serial Number field at the top to store your RATS serial number in

the registry. This allows you to view the serial number at any time by doing Help–

About RATS (RATS–About RATS on Macintosh). For convenience, you can also store

serial numbers for other RATS products (such as the CATS cointegration proce-

dures)—just separate the serial numbers by semi-colon (;).

Note: in some cases, the installation program may be able to save the serial number

in the registry automatically.

The remaining fields are described on the following pages.
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The Editor Tab
The first tab in the dialog box, labelled “Editor”, controls various settings affecting

the text editing features of the interactive mode interface.

Open NONAME Window at Start
This controls whether or not RATS automatically opens up an empty text window

each time you start the program.

Open Series Window at Start
Turn this on if you want RATS to automatically open the Series List window (display-

ing the series in memory) when the program starts.

Buffer Text Output
Turn this off if you want RATS to display each line of output as it is generated. Turn

it on if you want RATS to save output in a “buffer”, and only update the screen

periodically. The latter is usually much faster for programs that generate a great

deal of output.

Editor Font Button
You can change the font and type size used in the RATS editor by clicking on this

button. This controls the appearance of text both on the screen and when printed.

The current font and size are shown in the dialog to the right of the button.

Indenting
This controls how far (in terms of number of characters) lines will be indented if you

use the Indent Lines operation on the Edit menu.

Comment Length
This sets the maximum line width (in number of characters) that will be used if you

do the Format Comments operation on the Edit menu.

The Directories Tab
The “Directories” tab offers the following fields:

Default Directory
The Default Directory field allows you to change the default startup directory. If you

select a directory here, and answer “Yes” when RATS asks if you want to make the

changes permanent, that directory will be the default directory each time you start

the program. Note: use the File–Directory operation if you just want to change the

default directory for the current session.

Procedure Directory
If you try to execute a procedure that RATS has not yet compiled, it will automati-

cally search the current directory and the directory containing the RATS executable

file for a “.SRC” file with a name matching that of the procedure. You can use this

field to supply an additional search directory. So, if you have procedures you use

regularly, you may want to collect them in a specific directory, and enter the name of

that directory in this field. See Section 6.2.1 of the User’s Guide for details.
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Procedure Library
The Procedure Library field allows you to specify a file of procedures that you want

RATS to load automatically each time you start the program or clear the memory. See

Section 6.2.1 of the User’s Guide for details.

CATS Directory
If you have version 2.0 or later of our CATS cointegration analysis procedure, enter

the directory containing your CATS files here. This will allow you to use the CATS

Cointegration operation on the Statistics menu to launch the CATS procedure.

Global Insight (Citibase/DRI Basics) Directory
If you have a copy of the Global Insight (formerly DRI/Citibase) Basics Economics

database, you can use the “Global Insight Directory” field to tell RATS where these

files are located so that you can read data from those files into RATS using the

FORMAT=DRI option on the DATA instruction.

Batch Output .ext
This field lets you specify the extension that is appended to output files when run-

ning in batch mode.

The Graphics Tab
The Graphics tab provides the following fields:

Fonts for Label Types
You can use this field to set the default font, size, and style for the various labels

available on graphs generated by RATS. To change the settings for a label, select

(highlight) a label type and then click on the “Change” button. This displays a

standard font selection dialog box which you can use to select the font.

Note that you can override these defaults using the GRPARM instruction or the Graph

Settings operation on the Wizards menu.

One Graph Window Only
If this is on, RATS re-uses the same window each time you generate a new graph.

Otherwise, it displays each new graph in its own window. This can be handy when

running a “batch” program.



RATS Version 7

18 Getting Started

The RATS Menu Bar
The RATS Editor provides eight menus: File, Edit, View, Wizards, Data, Statistics,

Window, and Help. Most of these are very similar to those available in many other

Windows applications. We describe the menu operations briefly below. The on-line

help provides additional details on many of the menu operations.

The File Menu
The File menu provides standard file-handling and related operations.

New opens a new, empty, text window.

Open... opens an existing text file and displays its contents in a new

window. This will only be the input window if there are no other

open text windows. Use the Open Graph... operation to open a

graph file and Open RATSData to open a RATS data file.

Recent Files provides a list of the most recently used files. The list is preserved

from one session to the next, so you can easily reopen files you

were using in a previous session.

Close closes the active window. RATS will give you a chance to save any

changes before closing the window. If you close the input window,

RATS does a Clear Program operation (see next page).

Merge... inserts the contents of an existing file into the active window.

Save saves the entire contents of the active window to disk using the

current file name (Save will prompt you for a file name if the file

hasn’t been saved previously).

Save As... saves the contents of the active window to disk, using a filename

you select. If you have text selected in the window, Save As will

ask if you want to save the selected block, or the entire window.

Export... exports the contents of the active window to a file. This operation

is supported for most windows other than text windows (where

you just use File–Save As...). Export allows you to choose from a

variety of file formats.

Open Graph... opens a RATS graph (saved in RGF format) and displays it in a

graph window.

New RATSData, open a new or existing RATS format data file and display a

Open RATSData Datafile List window associated with that file. Toolbar operations

allow you to create new series, rename, view, or edit existing

series, and display graphs and summary statistics.
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The Open RATSData operation is also the first step in using the

RATS format Data Wizard to read data from a RATS data file into

memory. See Chapter 1 of the User’s Guide for details.

Page Setup... selects a printer, and allows you to set printer–specific options.

Print prints the contents of the active text or graph window. To print

just a portion of a text window, select the desired lines before

doing Print.

Directory... lets you change the default drive and directory for the current

session.

Preferences... customizes the behavior of the RATS editor. See page 15 for

details. On Macintosh versions, this operation is located on the

RATS menu.

Batch Mode puts RATS into “batch” mode. See page 33.

Clear Program clears the current RATS “program” (all data series, other vari-

ables, CALENDAR and ALLOCATE settings, etc.) from memory. Use

Clear Program (or the  icon) when you want to enter a new

program, or re-execute a program from the beginning. This does

not delete any text, close any windows, or close open data files.

Exit closes all windows and exits the RATS program. RATS will give

you an opportunity to save any changes before quitting. On

Macintosh versions, this operation is called Quit and is located on

the RATS menu.
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The Edit Menu
The Edit menu provides cut and paste and other editing functions. See the on-line

help for further details.

Undo “undoes” the recent changes. For example, if you have Cut a

block of text, Undo will replace the text. Undo also works with

data editing windows. You can “undo” up to the twenty most

recent changes in each window. Note that Undo never reverses

calculations—it applies only to editing operations.

Redo “redoes” the results of the most recent Undo.

Cut for a text window, this deletes the selected text and copies it to

the Clipboard. This can also be used to delete series from a

RATS format file when applied to a Datafile List window (the

deleted series can be pasted to another file if desired).

Copy copies the selected information to the clipboard for later

pasting, but does not delete it from the window. You can use

Copy to copy text, graphs, or the contents of a spreadsheet

window, or to copy-and-paste series from one RATS format file

to another.

Paste copies the contents of the clipboard into the active window.

Most commonly used for copying text, you can also copy-and-

paste (or cut-and-paste) series from one RATS format file to

another using Datafile List windows. Note that you cannot

paste graphics into RATS.

Delete deletes the selected text (does not copy it to the clipboard).

Select All selects every line in the window. To execute every instruction

in the input window, you can do Edit–Select All (or click on the

“Select all” icon) and hit <Enter> (or click the “Run” icon).

Find... searches for a string of text. You can search from the top of the

window, or forward or backward from the current cursor

position. Turn on the “Case Sensitive” check box for a case-

sensitive search.

Find Next repeats the most recent Find... operation.

Replace... does a find-and-replace operation, locating a specified string in

the active window, and replacing it with another string.

To Lower Case converts the selected lines to all lower-case.
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Format comments Takes the selected line(s) and turns them into a block of

comments (lines prefixed with an * that RATS will ignore

rather than execute as commands). The lines will be reformat-

ted to be of approximately uniform length. You can change this

length with the “Comment Length” box on the Preferences

dialog box.

Comment-Out Lines This turns the selected lines into comment lines, that will be

ignored by RATS when executing instructions. This is done by

adding the * symbol to the beginning of each line.

Uncomment Lines The opposite of the Comment-Out Lines operation, this re-

moves the * symbols from the beginning of the selected lines.

Indent Lines Indents the selected lines. You can change the width of the

indenting with the “Indenting” box on the Preferences dialog

box.

Unindent Lines Removes indenting from the selected lines. The amount of

indenting that will be removed is the indenting amount set via

the Preferences operation.

Show Last Error moves the cursor to the line (instruction) that caused the most

recent error.
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The View Menu
The View menu allows you to view lists of the variables and series currently stored in

memory and quickly generate simple graphs and statistical tables for series dis-

played in a Series List and Datafile List windows.

The following operations are always available:

All Symbols Displays a list of all global variable and function names,

including reserved variables and functions defined by RATS

as well as user-defined variables.

Series Window This brings up a window showing all the series currently in

memory. From this window, you can use the other View menu

operations or the toolbar icons to graph the series, display

basic statistics, export series, edit the series, and more.

The following operations are only available for certain types of windows.

Change Layout Reserved for future development.

Reset List When a Datafile List is active, this allows you to change which

series are listed, and whether the series are sorted by name.

Show as B&W When a Graph Window is active, you can use these operations

Show as Color to change the graph from color mode to black and white mode

or vice versa.

The following operations are only active when a series list or datafile list window is

active. These serve the same function as the corresponding toolbar icons (see pages

28-29). The last two operations apply only for a list of series in memory.

Time Series Graph Produces a time series graph of the selected series.

Histogram Produces a histogram plot of the selected series (can only be

applied to one series at a time).

Box Plot Produces box plots for the selected series.

Autocorrelations Produces a plot of the autocorrelations and partial autocorre-

lations for the series.

Statistics Produces basic descriptive statistics for the selected series

Covariance Matrix Produces a covariance\correlation matrix of the selected series

Data Table Displays the selected series as columns in a spreadsheet-style

window, similar to doing PRINT with the WINDOW option. Note

that you cannot edit series values using this data view—

double click on a series if you want to edit values in the

series.
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The Wizard Menus
RATS offers more than two dozen menu-driven Wizards, which provide easy point-

and-click access to many of the most important tasks available in RATS, including

reading in data, estimating regressions, generating forecasts, and much more.

With Version 7, the Wizard operations have been divided into three separate menus,

grouped by basic function:

• The Wizards menu provides some general tools, including access to lists of

reserved variables and functions, and the ability to control fonts and type

sizes for graph labels.

• The Data menu provides tools for working with data series, including reading

data in from a file and doing various data transformations.

• The Statistics menu is where you will find wizards for computing summary

statistics, doing least squares regressions, estimating various non-linear

models, testing hypotheses, and more.

These menu operations are described briefly beginning on the next page. Please see

Chapter 1 of the User’s Guide and the RATS Help system for full details on using the

Wizards.

Note: For some instructions, we have omitted some of the more esoteric options from

the corresponding Wizard, to keep the wizards from becoming cluttered or unwieldy.

For example, the GARCH and GRAPH instructions both offer options that are not

available via their respective Wizards.

If you need some of these additional capabilities not provided via the Wizards, you

can either type in the appropriate command(s) directly, or use a Wizard to generate a

basic version of the instruction(s) which you can edit as desired.
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The Wizards Menu
Paste AND Execute This is a “switch” controlling how the other Wizards

behave. When this is switch is on, clicking OK in a

Wizard dialog box automatically executes the

instruction(s) generated by the Wizard. If you would

prefer that the Wizard only insert the instructions

without executing them, select Paste AND Execute to

turn off this setting.

Show All Symbols Displays a list of all global variable and function

names, including reserved variables and functions

defined by RATS as well as user-defined variables.

Function This opens the Function Wizard, which you can use to

browse through the built-in functions, check the

function syntax, and paste a function into the input

window.

RATS Variable This provides access to all of the reserved variables

defined by various RATS instructions. You can view

an alphabetical list of all the variables, or list vari-

ables by category.

Graph Settings This generates a GRPARM instruction, allowing you to

set the font, style, and size of labels used on graphs.
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The Data Menu
Show Series Window This brings up a window showing all the series

currently in memory. From this window, you can use

toolbar buttons to graph the series, display basic

statistics, export series, edit the series, and more.

Calendar provides an easy way to enter the desired periodicity

and starting date for the current session. Note: If you

will be using one of the Data Wizards, there is no

need to do the Calendar Wizard.

Data (RATS format) The Data Wizards simplify the process of setting up

your RATS session, including setting the CALENDAR
and ALLOCATE commands, opening a data file, and

reading in data. If you will be working with a RATS

format file, first do File–Open RATSData to open the

data file, select the series you want to read in from

the file, and then do the Data (RATS Format) Wizard

to read in the data.

Data (Other formats) If you will be working with any format other than

RATS format, just select the Data (Other Formats)

Wizard. From the dialog box, select the desired file

format and open the file you want to read.

Trend/Seasonals/Dummies generates trend series, seasonal and 0/1 dummies, or

a series of draws from a random normal distribution.

Transformations provides a convenient way to do a variety of data

transformations, from taking logs or square roots to

generating growth rates, and more.

Differencing allows you to difference series using regular, seasonal,

and/or fractional differences.

Filter/Smooth implements several types of time-series filters.

Moving Window Statistics extracts means, variances, fractiles, and extreme

values from a moving window of data.

X11 (Pro version) implements the X11 seasonal adjustment process.

Note: This feature is only supported in the Profes-

sional version of RATS.

Graph generates time series graphs.

Scatter (X-Y) Graph generates scatter plots.
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The Statistics Menu
Univariate Statistics generates descriptive statistics for a single series.

Cross Correlations computes cross correlations and covariances for a pair

of series.

Covariance Matrix computes a variance/covariance matrix for a set of

series.

Equation/FRML definition defines an equation or formula. For formulas, you can

define the list of nonlinear parameters.

Regressions performs a variety of linear regressions, including

OLS, instrumental variables, GMM, and AR1.

Limited/Discrete performs estimations involving limited and discrete

Dependent Variables dependent variable models, such as probit and tobit.

Panel Data Regressions performs panel data regressions, including fixed and

random effects.

Regression Tests does hypothesis testing on the most recently com-

pleted regression.

ARCH/GARCH estimates univariate and multivariate ARCH, GARCH,

and related models.

Box-Jenkins (ARIMA) Models estimates ARIMA models.

Exponential Smoothing implements exponential smoothing.

VAR (Setup/Estimate) defines and estimates VAR models.

CATS Cointegration If you have version 2 of the CATS cointegration

analysis procedure (sold separately), you can use this

operation to execute the procedure.

Single-Equation Forecasts generates forecasts for a single equation.

VAR (Forecast/Analyze) generates forecasts, impulse responses, variance

decompositions, and historical decompositions for

VARs and other multi-equation models.



Getting Started

Getting Started 27

The Window Menu
The Window menu offers several operations for working with RATS windows. Also, a

list of all open windows appears at the bottom of the Window menu. You can switch

to a window by selecting it from this list.

Tile Horizontal “tiles” the open windows so they are all visible on the screen,

using a horizontal orientation (windows will be wider than they

are tall).

Tile Vertical tiles the open windows, using a vertical orientation (windows will

generally be taller than they are wide).

Cascade stacks the open windows so the title bar of each window is visible.

Close All closes all open windows. RATS will give you a chance to save any

changes to text windows.

Close All Graphs closes all graph windows. You will not be asked if you want to

save changes, so if you want to save any of your graphs, be sure to

do so before selecting this operation.

Close All Reports closes all spreadsheet windows created using WINDOW options.

Use for Input makes the active text window the input window.

Use for Output makes the active text window the output window.

Restore Report displays a recent “report” in a window. You can use this to re-

display the formatted output produced by instructions like

REPORT, LINREG, TABLE, STATISTICS, and many others. You can

restore (in reverse order) up to twenty reports. From the report

windows, you can copy, paste, and export information to spread-

sheet programs and other applications.
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The RATS Toolbars
The RATS and RATSDATA toolbars provide icons you can click on to accomplish a

variety of tasks. The toolbar appears at the top of the screen, just below the menu

bar. Note that many of the graph window and series list operations are also available

via the View menu.

Text Editing Windows
The following icons appear in the toolbar when a text window is active. Some icons

are disabled (and appear dimmed) under certain conditions.

  (Open) Shortcut for File–Open. Opens a text file.

  (Save) Shortcut for File–Save. Saves the contents of the active window.

  (Print) Shortcut for File–Print. Prints the contents of the active window.

  (Functions) This opens the Function Wizard. See Chapter 1 of the User’s

Guide for details.

  (Input) This designates the active (front) window as the Input window.

It is equivalent to the Window–Use for Input operation.

  (Output) This designates the active (front) window as the Output win-

dow. It is equivalent to the Window–Use for Output operation.

, These set up split Input and Output windows, tiled horizontally

or vertically—see page 14.

  (Select All) Shortcut for the Edit–Select All operation. Selects all the text or

items in the active window.

  (Run) Runs the selected instructions, or the instruction on the cursor

line, if any (equivalent to hitting <Enter>). Disabled if the

active window is not the input window.

  (Stop) While RATS is processing instructions, the “Run” icon changes

to this “Stop” icon. You can click on this to halt the processing

of the instructions.

  (Ready/Local) This switches RATS from Ready to Local mode. The icon will

change to “Local/Ready” ( ), indicating that RATS is in Local

mode. Click the icon again to change back to Ready mode. You

can also hit <Ctrl>+L to switch between modes. See page 9 for

details. This is omitted on Macintosh versions, where you can

insert a carriage return by hitting the <Return> key.

  (Clear Mem.) This clears the memory. It is equivalent to File–Clear Program.
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Graph Windows
When a graph window is active, RATS will display the “Save” and “Print” icons

described above, along with the following icons (see Chapter 3 of the User’s Guide for

more details on these):

  (Fix) Clicking on this icon “fixes” the graph proportions. Resizing the

graph window will change the size of the graph, but not its

proportions or general appearance. If you then print or save the

graph (in any of the available file formats), the graph will be

printed or saved using these fixed proportions.

  (Unfix) When you fix the proportions of a graph, the “Fix” icon changes

to the “Unfix” icon. If you click on “Unfix,” RATS will be free to

change the proportions of the graph whenever you re-size the

graph window.

 (Grayscale) By default, graphs are displayed in color (unless you use the

PATTERNS option). Clicking on this button switches the graph

to black and white mode. The icon will change to a multi-

colored version, indicating that clicking the button again will

switch the graph window back to color mode.

Series List Windows
The following icons are available when you display a Series List window (a list of the

series stored in memory) by selecting the View–Series Window or Data–Show Series

Window operations:

  (Select All) Shortcut for the Edit–Select All operation. Selects all the series

in the list.

  (Graph) displays a time series plot for the series.

  (Histogram) displays a histogram plot for the series.

  (Box Plot) displays a box plot for the selected series.

  (Autocorr.) computes and graphs the autocorrelations and partial autocor-

relations of the series.

  (Statistics) computes and displays descriptive statistics for the selected

series, including the number of observations, mean, standard

error, and maximum and minimum values of each series.

 (Cov./Corrr.) computes and displays a covariance and correlation matrix for

the selected series.
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  (Data View) displays a spreadsheet-style window showing the selected

series. In addition to viewing the series, you can copy and paste

the contents of the window into another application, or use

File–Export... to export the contents to a file. Although this

Wizard does not generate an instruction, it is equivalent to

doing a PRINT instruction with the WINDOW option.

Datafile List Windows
When you display a Datafile List window (a listing of the series stored in a RATS

format data file) by selecting the File–Open RATSData operation, the first six icons

for the Series List window are available, plus three additional icons:

  (Layout) This brings up the “List Which Series” dialog box, which allows

you to control which series are listed based upon their names or

comments, and choose whether the list will be shown by name,

or the order in which the series are stored on the file.

  (New Series) Adds a new series to the file. RATS will display a dialog box

allowing you to specify the structure and frequency for the

series, and then will open a Series Editing Window to enter

values for the series. When you are finished entering values,

close the editing window. RATS will prompt you for a name for

the series, and then will add the series to the file.

  (Rename) allows you to change the name of the selected series.

The menu-driven RATSDATA utility program uses the same window format. You may

find it handy to use RATSDATA for converting data to and from RATS format files, or

for quickly creating or editing series or generating graphs (see the Help system in

RATSDATA for details). However, virtually all of the functionality of RATSDATA has

now been incorporated in RATS itself. So, in most cases you will probably find it

easiest to just use the File–New RATSData and File–Open RATSdata operations in

RATS to do this kind of work.

Series Editing Windows
The following icons are available when editing a series (either a series in memory or

a series on a RATS format file):

  (Insert) Inserts a new cell at the current cursor position (cell value is

set to NA).

  (Remove) Removes the current cell and shifts the remaining data one

position to the left to fill its place.
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  (NA) Sets the current cell to the missing value code (NA, or Not

Available).

  (Undo) “undoes” the current operation. Equivalent to Undo on the Edit

menu.

  (Max. value) moves the cursor to the cell containing the largest (maximum)

value in the series.

  (Min. value) moves the cursor to the cell containing the smallest (minimum)

value in the series.

  (Graph) displays a time series plot for the series.

  (Histogram) displays a histogram plot for the series.

Please see the on-line help for further details on using data editing windows.
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Interactive Help
RATS includes an extensive help facility. The Windows version uses the standard

Windows help system, which makes it easy to search for help on a topic, jump to

related topics, move back and forth through previously viewed help topics, and so on.

You can even copy information (such as the syntax for a RATS instruction) from a

help window into a RATS window.

The help system provides information on using the RATS editor, brief descriptions of

every RATS instruction, and general tips on getting started with RATS.

Accessing Help (Windows)
On Windows systems, you can open the main RATS help screen by hitting <F1> while

RATS is active, or selecting Contents from the RATS Help menu. This provides a brief

introduction to the help system, and provides a choice of a number of general help

categories. Just click on any of the links to jump to that topic.

Menus and toolbar icons at the top of the window allow you to access various special

features of the Help system. For general instructions on using the help system, select

Using Help from the RATS Help menu or, if you’ve already opened the help screen,

choose How to Use Help from the help screen’s Help menu. To get help on a particu-

lar topic, select Help–Search. This allows you to do a keyword search through the

available help topics.

Accessing Help (Macintosh, UNIX, Linux)
On Macintosh, UNIX, and Linux systems, the Help system is supplied in the form of

HTML format files. Clicking on the “help” icon in your RATS folder will open the main

Help page in your Web browser. You can then use the links to access the various help

topics. Note that you do not need to be connected to the internet for this to work. The

help files are all stored in the RATS directory on your computer.
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Section V: Using RATS in Batch Mode
Batch Mode

In batch mode, RATS automatically reads instructions from a text file and stores the

resulting output in another (new) file. This is very convenient for running long

programs, because you can start RATS and then leave the computer unattended

while it executes the program. You can create these programs using the RATS editor

or any word-processing program that can save files as plain (unformatted) text.

Similarly, you can view the output with RATS or any other word-processor.

Running Programs in Batch Mode
There are three ways to run WinRATS in batch mode (please see the “ReadMe” file

included with MacRATS and the UNIX/Linux installation guide for details on running

in batch mode on those platforms).

One method is to start RATS, put it into batch mode using the Batch Mode operation

on the File menu, and then drag and drop your program files from Windows Explorer

or a similar utility onto the active RATS application. This is most useful if you have

several programs that you want to run.

Another method is to run from a command prompt—either via the Run operation on

the Start menu, or by opening the “Command Prompt” shell. You simply type the

name of the RATS application itself, followed by the name of the program you want to

execute and the command-line switch “/RUN”.

Finally, you can execute RATS in batch mode from a short cut icon. This method is

most useful if you have a particular program that you need to run frequently.

In any case, RATS will automatically run the specified program(s), and save the

output in a new file (or files) with the name filename.ext, where filename is the name

of the input file, and ext is the “batch mode extension” specified in the File–Prefer-

ences... operation in RATS (the default extension is LIS). The file(s) will be saved in

the same directory as the program file(s).

Details on all three methods follow:

Drag and Drop Method
To run a program as a batch job using the drag and drop method, do the following:

1. Start RATS.

2. Switch RATS into batch mode by selecting the Batch Mode operation from the

File menu.

3. Open Windows Explorer and arrange the screen so that you can see both the

WinRATS window and the Explorer window on the screen at the same time.

4. Select one or more program files from Explorer, drag the file icon(s) over to

the WinRATS window, and release the mouse button.
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You can drag and drop the files one at a time, or you can drag and drop several files

simultaneously. Note that a check mark appears next to the Batch Mode operation

on the menu while RATS is in batch mode. To switch back to interactive mode, just

select the Batch Mode operation again.

If you use batch mode frequently, you may want to create a copy of the WinRATS icon

that will automatically start RATS in batch mode. Here’s how:

1. Make a copy of the WinRATS program icon (see your Windows documentation

or help for details).

2. Right-click on the RATS icon to display the properties dialog for the new icon.

3. Set the icon to “Run minimized” and click on OK.

Now, when you double click on this new icon, RATS will automatically start up with

the Batch Mode switch turned on. You will need to click on the minimized icon to

open it up into a window. You can then drag and drop program files onto the window.

Command Prompt Method
If you are comfortable with using the Command Prompt shells in Windows, or are

used to using the older DOS version in batch mode, you may find this method useful.

You simply need to open the Command Prompt window from within Windows, and

then type in the name of the RATS executable file (RATS32S for WinRATS, RATS32SX
for WinRATS Professional), the name of the input file, and the “/RUN” switch, sepa-

rated by spaces. For example, the command line for WinRATS might look like:

c:\winrats\rats32s c:\test\myprog.prg /run

This will run the job and save the output to MYPROG.LIS (unless you have used File–

Preferences in WinRATS to change the default output filename extension). You can

include commands like this in a DOS batch (.bat) file if desired.

Short Cut Icon Method
There are several ways to create shortcut icons—see your Windows on-line help or

documentation for details. One method is to right-click on the desktop, and select

New–Shortcut from the pop-up menu.

In the command line, enter the command to run the desired program, just as shown

under “Command Prompt Method” above.

Click on the “Next” button, enter a name for the icon, and click on the “Finish”

button. This will create the batch job icon on your desktop—you can double-click on

this to run the job.
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Command Line Switches
RATS offers several command line “switches” to control batch mode operation—these

can be used with both the “Command Prompt” and “Shortcut Icon” methods of

running in batch mode:

/NOSHOWGRAPHS Suppresses display of graphs in batch mode.

/PRINTGRAPHS Prints graphs as they are generated.

/PLOT=filename Saves graphs to the specified plot file. Equivalent to putting an

OPEN PLOT instruction in your program.

/DATA=filename Opens the specified file as the DATA unit. Equivalent to an

OPEN DATA instruction.

/COPY=filename Opens the specified file as the COPY unit. Equivalent to an

OPEN COPY instruction.

/PROC=filename Designates filename as a Procedure Library file—the com-

mands in this file will automatically be processed before the

specified program file is executed.

To use a particular switch, just add it to the end of the command line (you can use

more than one switch if you wish). For example:

c:\winrats\rats32s /run /noshowgraphs /plot=myplot.rgf

executes the instructions in MYPROG.PRG, saves the graphs in the file MYPLOT.RGF,

but does not display the graphs to the screen.
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Section VI: File Handling and File Names
How RATS Uses Files

RATS uses files for several purposes:

• RATS instructions

• Data input

• Program output

• Data export

• Graphs

If you are working in interactive mode, you open program files with the File–Open...

operation, and save output or graphs using the File–Save As... operation.

Most other file operations are handled using the OPEN instruction. For example,

opening and reading a data file is handled with an instruction of the form:

open data mydata.rat
data(format=rats)

In the OPEN command above, “DATA” is the name of the Input/Output unit associated

with the file name. We use it here because DATA is the default unit used by the DATA
command. COPY is the command most commonly used to write data to a file, and as

you might expect, the default unit name for the COPY command is “COPY”, so we

normally use a command of the form:

open copy export.rat
copy(format=rats)

to write out data. See the OPEN command in the Reference Manual for more on I/O

units and opening files.

Two other instructions, SOURCE and DEDIT, are also used for working with files:

• SOURCE temporarily switches the input source to a file. This is most commonly

used to read in and compile procedures stored on separate files, such as the

.SRC files supplied with RATS.

• DEDIT initiates editing of a RATS format data file.
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Specifying File Names
Wherever RATS requires a file name, you can use any legal file name as long as the

total length is no greater than 255 characters. If you give the name of a non-existent

file for an INPUT, DATA or SOURCE file, RATS will print an error message and prompt

you for the proper file name.

If you are writing an instruction that uses a file name or path that includes blank

spaces, you need to enclose the entire name in quote marks:

source "c:\myfiles\long program name.prg"

On Macintosh and UNIX systems, use a forward slash (/) to separate drive and folder

names:

source "/myfiles/long program name.prg"

If you set a default search path (with File–Directory), RATS will add that path to any

file name which does not include either a drive or path specifier.

While it is not required, we would suggest that you use a .RAT extension for RATS

format data files. We also suggest that you use .PRG, .RGF, and .SRC extensions for

program, graph, and procedure files, respectively. However, RATS does not make any

assumptions about the format of a file based on its extension, so you can use any

extensions you like.
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Section VII: Technical Support
Introduction

Support is not cheap, but we think it is an important part of what you have paid for.

The next three pages describe the procedures for obtaining support and the level of

support which you can expect from us.

Your Serial Number
Your serial number will be printed on a label on the CD jacket. This serial number is

your key to updates and technical help. As described on page 15, you can use the

File—Preferences operation to store your serial number in the registry for later

reference. You may also want to write the serial number in your manual, or some-

where else handy where you can find it.

If you are a new purchaser, please fill out the “registration/address change” form

available on our website. This is especially important if you bought the program

through a dealer or through your purchasing department as we will be unable to

send you newsletters and other notices without an address.

When contacting technical support, please supply your serial number so we can

verify which version of RATS you are using.

Can RATS Do ...?
Many of these questions can be answered by checking the index and the table of

contents in the manuals carefully, or by visiting our web site (www.estima.com),

where your question may be addressed by the list of Frequently Asked Questions or

by one of the many procedures and example programs available for downloading.

If you can’t find the answer there, you can e-mail, fax, or call our technical support

department with your question. The answers to these sorts of questions generally fall

into four categories:

1. Yes (and you should have known it by looking at the index or table of con-

tents). Please be sure to check these first.

2. Yes, you can use the instruction ...

3. Yes, but it takes a little work (a short sequence of instructions).

4. No, or at least it would be very difficult and require extensive programming.

Many of the suggestions made by users have helped to improve our product, so we

try to be as helpful as we can. With types 2 and 3, we will usually tell you exactly

how to do it. However, with type 4, we can only give you a general idea of what you

have to do if you decide to press on.
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Statistical Questions
RATS has many capabilities which may be unfamiliar to some of you. If you decide to

explore some new territory, we will be happy to steer you to some good references or

to explain how RATS does particular computations. However, while we can help to

clear up basic misunderstandings about the use of the RATS instructions, we cannot

give involved statistics lessons over the phone. If you are interested in discovering

new techniques, watch the newsletter for information regarding workshops.

Bugs and Potential Bugs
In a program as complex as RATS, there are undoubtedly some bugs remaining. In

addition, because RATS has many features of a programming language, it is quite

possible for you to experience problems due to errors in your own code. The more

complex your program, the more likely it is that the latter is true. If your program is

not running correctly, you should do the following:

• Check carefully that you are using the proper syntax on the instruction(s)

causing the problem. See the Reference Manual in particular.

• If you are doing extensive operations with loops and COMPUTE instructions,

put in some debugging statements (DISPLAY and PRINT are the most useful

for this) to see where things go awry.

• Check the list of frequently asked questions, and the list of known bugs,

available on our web site (www.estima.com).

• If, after all this, you have a strong suspicion that you have located a bug,

contact Technical Support. If you have done a thorough job on the preceding

steps, you can often ask a direct question such as “Is there a known bug in

....?”, and we may be able to give you a quick answer. If you have not been able

to isolate the problem, we will almost certainly have to ask you to send us the

input file and data and as much other information as you can supply.

The RATSletter
The RATSLetter is a newsletter for registered users. We distribute it (approximately)

twice a year. It includes new product announcements, answers to common questions,

bug reports, tips on the use of the program, lists of contributed procedures, among

others. We would appreciate questions of general interest and suggestions. If you

have a program or part of one which you are proud of, send it in and let the rest of

the RATS community see it.

The Estima Web Site, User Forum, and the Email Discussion List
We invite you to visit our Web site at:   http://www.estima.com

The site offers news and information on RATS and other Estima products, answers to

frequently asked questions, and many examples and procedures you can download.

You will also find links to our online discussion forum and information on an e-mail

discussion list devoted to RATS.
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Contacting Estima Technical Support
If you have access to e-mail, this is probably the best way for you to obtain technical

support. You can provide us with a copy of your program and data set, and other very

specific information about the nature of your question. This makes it much easier for

us to resolve the problem or question, and to provide detailed answers. Most ques-

tions are answered within just a few hours. You can also contact us by calling the

technical support number listed below. Technical support is available from Monday

through Friday, 9 am to 5 pm US Central time. You can also reach us by fax or

regular mail.

When you contact technical support please be able to provide the following:

1. Your serial number (found on the label on the CD envelope). We do spot

checks to make sure that only those who have paid for the product get

support.

2. The product name and version number (also from the original disks).

3. As much detail about your question as possible. In particular, if you are

getting an error message you don’t understand, be sure to include that error

message in your e-mail, or have it handy to read to us over the phone. RATS

produces fairly specific and detailed error messages, so providing the specif-

ics of any errors you encounter will make it much easier for us to diagnose

the problem.

You can contact technical support at:

Voice: (847) 864-1910

E–mail: support@estima.com

Web site: http://www.estima.com

FAX: (847) 864-6221

Mail: Estima

1560 Sherman Ave, Suite 510

Evanston, IL 60201

If you write or FAX us with a question, please remember to include your name and a

phone or FAX number.


